- +

BMW Einzylinder-Forum

Bitte loggen sie sich ein oder registrieren sie sich.

Einloggen mit Benutzername, Passwort und Sitzungslänge
Erweiterte Suche  

Autor Thema: Suche geht nicht mehr?  (Gelesen 1886 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Rütz

  • Oldi-Liebhaber
  • Forums-Urgestein
  • ******
  • Karma: 145
  • Offline
  • Beiträge: 6587
  • Seit 1983 mit R27 unterwegs...
    • 51647
    • Gummersbach
  • Mitglied seit: 21/08/2002
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Suche geht nicht mehr?
« am: 17 Dezember 2006, 17:31:21 »

Hilfe Karl, ich komme mit der Forumssuche nicht mehr zurecht.

Wenn ich z.B. "Kurbelwelle" oder "Zündung" eingebe, erscheinen hunderte von Beiträgen, in denen aber keine Spur von "Kurbelwelle" oder "Zündung" zu finden ist. :o

Ich habe dann rumexperimentiert, aber es scheint keine Logik zu geben:
"Kurbelwelle Zündung" geht,
"Kurbelwelle Lager" geht nicht, :o
"Kurbel Lager" wiederum geht (um Beiträge mit Kurbelwelle und Lager zu finden)
"Kugellager" geht nicht....


Anselm F(indnix)
Gespeichert
"Das Gegenteil von Freiheit ist Gesundheit"  (Juli Zeh, 2017)

BMW Einzylinder-Forum

Suche geht nicht mehr?
« am: 17 Dezember 2006, 17:31:21 »

Karl

  • Global Moderator
  • Forums-Urgestein
  • *****
  • Karma: 126
  • Offline
  • Beiträge: 7811
  • BMW R25/0
    • 63065
    • Offenbach
    • Hessen
    • Deutschland
  • Mitglied seit: 25/06/2002
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #1 am: 18 Dezember 2006, 11:51:42 »

Hi Anselm,

hab' mal alles gecheckt; scheint leider ein Fehler in der Suchfunktion zu sein  :(
Hab mal bei den Programmierern nachgefragt und warte auf eine Antwort.

Grüße,
Karl
Gespeichert
Vorsicht! Dieser Beitrag kann Spuren von Ironie oder Sarkasmus enthalten. Ohne Konservierungsstoffe (lt. Gesetz). Ohne Farbstoffe. Ohne geschmacksverstärkende Zusatzstoffe. Deckt 2% des Richtwertes des täglichen Benzintalkbedarfs.

Peter

  • Oldi-Liebhaber
  • Oldtimer-Veteran
  • *****
  • Karma: 24
  • Offline
  • Beiträge: 2509
  • R25/3,R69,R1150GS,MG V7,TR4,R1100GS+URAL
    • 96450
    • Coburg
    • Bayern
    • Deutschland
  • Mitglied seit: 28/06/2002
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #2 am: 19 Dezember 2006, 08:22:26 »

Hi Karl, dann ergänze doch deine Fehlermeldung an die Entwickler dahingehend, daß ein Suchen über bestimmte ausgewählte Themen auch nicht mehr funktioniert. Vor ein paar Tagen habe ich versucht eine Suche auf wenige Themenbereiche einzuschränken, ich habe aber Ergebnisse auch für Themenbereiche bekommen, die ich nicht mit einem Häkchen versehen habe!
Gruß Peter
Gespeichert
Am Sichersten ist die Unfreiheit

cledrera

  • Oldi-Liebhaber
  • Forums-Urgestein
  • ******
  • Karma: 90
  • Offline
  • Beiträge: 13804
  • Lieber Einzylinder als zwei Fallschirme
    • Köln
  • Mitglied seit: 04/06/2006
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #3 am: 19 Dezember 2006, 13:07:26 »

Jungs,
könnte es sein, dass der Programmierer für das Einzylinderforum eine Vierzylindersuchmaschine programmiert hat?
Falls ja,  :wikinger: :attacke: :box:

cledrera
Gespeichert
Du bist im Recht; nun sieh zu, wie du da wieder heraus kommst. (v. Chamisso)

Karl

  • Global Moderator
  • Forums-Urgestein
  • *****
  • Karma: 126
  • Offline
  • Beiträge: 7811
  • BMW R25/0
    • 63065
    • Offenbach
    • Hessen
    • Deutschland
  • Mitglied seit: 25/06/2002
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #4 am: 19 Dezember 2006, 13:32:35 »

Jungens, immer mal sachte! So wie ich die Hersteller & Programmierer des Boards kenne, wird da ganz fix eine Lösung gefunden werden.

Normalerweise kann ich kleinere Problemchen selber schnell lösen, aber in diesem Fall gibt es eine komplett neue Such-Funktion, welche von Grund auf erneuert wurde. Und wie es mit neuen Dingen immer so ist > sie haben manchmal Kinderkrankheiten! Ich kann euch nur sagen dass die Jungs vom Programmiererteam am Problem dran sind und es (hoffentlich) bald eine Lösung gibt.

Beste Grüße,
Karl
Gespeichert
Vorsicht! Dieser Beitrag kann Spuren von Ironie oder Sarkasmus enthalten. Ohne Konservierungsstoffe (lt. Gesetz). Ohne Farbstoffe. Ohne geschmacksverstärkende Zusatzstoffe. Deckt 2% des Richtwertes des täglichen Benzintalkbedarfs.

Karl

  • Global Moderator
  • Forums-Urgestein
  • *****
  • Karma: 126
  • Offline
  • Beiträge: 7811
  • BMW R25/0
    • 63065
    • Offenbach
    • Hessen
    • Deutschland
  • Mitglied seit: 25/06/2002
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #5 am: 01 Februar 2007, 08:27:29 »

Hallo Allerseits,

da es "im Westen nichts Neues" gibt bezüglich der Suchfunktion, mußte ich mir selber weiterhelfen. Ich habe die Forumssuche einer älteren Version des Forums eingebaut. Das funktioniert zwar, aber nicht zu 100% (zB die Anzeige und Sortierung nach Relevanz funktioniert nicht). Aber besser als garnicht denke ich, oder?

Viele Grüße,
Karl
Gespeichert
Vorsicht! Dieser Beitrag kann Spuren von Ironie oder Sarkasmus enthalten. Ohne Konservierungsstoffe (lt. Gesetz). Ohne Farbstoffe. Ohne geschmacksverstärkende Zusatzstoffe. Deckt 2% des Richtwertes des täglichen Benzintalkbedarfs.

Rütz

  • Oldi-Liebhaber
  • Forums-Urgestein
  • ******
  • Karma: 145
  • Offline
  • Beiträge: 6587
  • Seit 1983 mit R27 unterwegs...
    • 51647
    • Gummersbach
  • Mitglied seit: 21/08/2002
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #6 am: 03 November 2007, 23:26:43 »

Hallo Karl,

als ich mich mal wieder über unsere Suche geärgert habe, bin ich auf die SMF Seite gegangen und habe mal deren Forumssuche (http://www.simplemachines.org/community/index.php?action=search) ausprobiert.
Dort funktioniert es wohl wieder:
- Man kann nach Zahlenkombinationen suchen.
- Man kann nach Begriffen mit weniger als 5 Zeichen suchen.
- Sie findet auch Wordteile! Findet also z.B. Besucher, besuchen, Suche, suchen, brauchen..... wenn man nur "uche" eingibt.

Liegt das jetzt an der neuen Version "SMF 2.0 Beta 1" und wir können hoffen, oder ist bei uns ein ärgerer Wurm drin?

Gruß Anselm
Gespeichert
"Das Gegenteil von Freiheit ist Gesundheit"  (Juli Zeh, 2017)

Karl

  • Global Moderator
  • Forums-Urgestein
  • *****
  • Karma: 126
  • Offline
  • Beiträge: 7811
  • BMW R25/0
    • 63065
    • Offenbach
    • Hessen
    • Deutschland
  • Mitglied seit: 25/06/2002
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #7 am: 04 November 2007, 12:49:43 »

Hallo Anselm,

ich denke das Problem mit der Suchfunktion ist tiefgehender als angenommen...

Zur Historie des Forums:

- ursprünglich war das Forum ja ein "YABB1.0"-Forum, welches keine Datenbankanbindung hatte und sämtliche Beiträge in Textdateien speicherte. Im Laufe der Zeit (mit steigenden Beiträgen) wurde das Forum unglaublich langsam, bis tlw garnichts mehr ging. Das war die Zeit, als unsere BMW-Seite noch auf diesen "kostenlosen" Plattformen (die mit den Werbebannern) betrieben wurde

- dann ist das Forum zu Strato gewechselt und hatte ab sofort ne Datenbank. SMF bot ein kleines Konvertierungs-Tool an, welches die Beiträge/Mitgliederdaten/Statistiken/etc ausliest und in SMF-konformer Weise in die Datenbank einfügt. Funktionierte alles einwandfrei. Leider war SMF damals auch noch in der Entwicklung (ich glaub wir begannen damals mit der SMF-Version 0.8 oder so) und bei Weitem noch nicht ausgereift.

- Es gab zig Entwicklungssschritte von SMF, das Forum erhielt neue Funktionen, wurde in der Geschwindigkeit beschleunigt usw. (heute sind wir bei Version 1.1.4) Doch sämtliche Updates mussten auch mit den Datenbankeinträgen durchgeführt werden (Daten aus dem alten Format ins Neue konvertieren).

- Ich VERMUTE mal dass während eines Updates der Datenbank irgendwo ein Fehler passiert ist bzw dass ein Update-Schritt nicht vollzogen wurde, so dass die Suchfunktion nicht mehr geht ("Suche" erfordert Datenbank im neueren Standard, DB ist aber noch auf Stand 1.0.x oder so). Und um diesen Fehler auszubügeln müsste die ganze Datenbank auseinander genommen und gecheckt werden - und soweit bin ich leider (noch) nicht in der Materie drin.  :-\\

Dass SMF mit Version 1.1.4 eine funktionierende Suche hat ist mir bekannt - das Boxerforum (welches ich als "Testwiese" für Updates benutze) funktioniert einwandfrei.

Soweit ich mich aber erinnern kann ist SMF 2.x angekündigt - vielleicht behebt ein Update auf diese Version ja den Fehler? Bleibt abzuwarten - ich bleib am Ball...

Viele Grüße,
Karl
Gespeichert
Vorsicht! Dieser Beitrag kann Spuren von Ironie oder Sarkasmus enthalten. Ohne Konservierungsstoffe (lt. Gesetz). Ohne Farbstoffe. Ohne geschmacksverstärkende Zusatzstoffe. Deckt 2% des Richtwertes des täglichen Benzintalkbedarfs.

kampfmaus

  • Gast
Re: Suche geht nicht mehr?
« Antwort #8 am: 18 Juli 2009, 13:53:17 »

Wenn ich bei "Suche" nur bzw. auch den Moped-Typ eingebe (z.B. "R25/2"), kommt die Ansage: "Jedes Wort muß mindestens zwei Buchstaben enthalten". Das würde ja bedeuten, daß Beiträge gezielt zum gewünschten Moped-typ garnicht gesucht werden können.

Ist das so oder kapiere ich da was nicht? Zugegeben - bin kein großer PC-Künstler.
Gespeichert

Beach

  • Schrauber-Lehrling
  • *
  • Karma: 0
  • Offline
  • Beiträge: 61
  • R27 Jedenfalls größtenteils.
  • Mitglied seit: 16/02/2009
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #9 am: 18 Juli 2009, 14:13:05 »

Es ist schon gut möglich das die Suchfunktion hier diese Beschränkung hat. Und ich nehem an, das man auch im Administrationsbereich da keinen großen Einfluß drauf hat.
Der wirkliche Sinn hinter solchen Einschränkungen konnte ich noch nie nachvollziehen. Hat aber wohl als Hintergrund das man damit den DB-Server entlasten will, denn wenn man nur nach einem Buchstaben sucht, gibt es entsprechend viele Treffer. Was bei vielen Anfragen zu einer hohen Serverlast führt.
Wird man auch ohne am QC zu frickeln wenig dagegen machen können.... Vermute ich jedenfalls
« Letzte Änderung: 18 Juli 2009, 14:19:44 von Beach »
Gespeichert
Shit happens!

Rütz

  • Oldi-Liebhaber
  • Forums-Urgestein
  • ******
  • Karma: 145
  • Offline
  • Beiträge: 6587
  • Seit 1983 mit R27 unterwegs...
    • 51647
    • Gummersbach
  • Mitglied seit: 21/08/2002
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #10 am: 18 Juli 2009, 15:23:05 »

Das hat mich auch schon geärgert... aber wie Beach sagt, wahrscheinlich nicht zu ändern. :-\\

Das Problem entsteht dadurch, daß Sonderzeichen wie "/" von der Suche völlig ignoriert, bzw. mit Leerzeichen gleichgesetzt werden, werden (obwohl sie für uns ja teilweise von erheblicher Bedeutung sind..).
Für die Suche ist es gleich, ob man "R25/2" oder "R25 2" eingibt ( :spinnt:)... und schon hat die "2" nur noch einen Buchstaben.

Rütz
Gespeichert
"Das Gegenteil von Freiheit ist Gesundheit"  (Juli Zeh, 2017)

Beach

  • Schrauber-Lehrling
  • *
  • Karma: 0
  • Offline
  • Beiträge: 61
  • R27 Jedenfalls größtenteils.
  • Mitglied seit: 16/02/2009
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #11 am: 18 Juli 2009, 16:27:46 »

Die Änderung wäre nicht das große Problem. Aber es besteht einfach die Gefahr, das ein solcher Hack beim nächsten Update wieder verschwunden ist...
Gespeichert
Shit happens!

† odeon8

  • Oldi-Liebhaber
  • Oldtimer-Veteran
  • *****
  • Karma: 88
  • Offline
  • Beiträge: 4206
  • BMW R26 * R34/4 * R75/5
  • Mitglied seit: 09/02/2003
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #12 am: 18 Juli 2009, 21:39:35 »

Man kann das Problem dadurch umgehen in daß man
den Suchbegriff in Anführungszeichen schreibt, ähnlich wie in
der Google-Suche bei zusammenhängenden Begriffen. So werden
Leerzeichen bzw. "/" (Slash) mitgesucht.

Die Forums-Suche nach "R25/2" MIT Anführungszeichen funzt einwandfrei;
bringt R25/2 genau so wie R25-2.

Thomas
Gespeichert
HUBRAUMISTDURCHNIXZUERSETZENAUSSERDURCHNOCHMEHRHUBRAUM

Rütz

  • Oldi-Liebhaber
  • Forums-Urgestein
  • ******
  • Karma: 145
  • Offline
  • Beiträge: 6587
  • Seit 1983 mit R27 unterwegs...
    • 51647
    • Gummersbach
  • Mitglied seit: 21/08/2002
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #13 am: 19 Juli 2009, 02:04:58 »

Tatsächlich! :o
Das war aber nicht immer so. Ich habe vor einiger Zeit mal verzweifelt versucht nach einer E-Teilnummer zu suchen und habe es auch definitiv mit "" versucht (steht ja auch drunter: "Spiele PC"). Wegen der Leerzeichen wollte es aber nicht klappen... jetzt geht's. :D
Gespeichert
"Das Gegenteil von Freiheit ist Gesundheit"  (Juli Zeh, 2017)

kampfmaus

  • Gast
Re: Suche geht nicht mehr?
« Antwort #14 am: 19 Juli 2009, 16:48:53 »

Klappt !!!
Danke!
Gespeichert

Karl

  • Global Moderator
  • Forums-Urgestein
  • *****
  • Karma: 126
  • Offline
  • Beiträge: 7811
  • BMW R25/0
    • 63065
    • Offenbach
    • Hessen
    • Deutschland
  • Mitglied seit: 25/06/2002
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #15 am: 20 Juli 2009, 09:20:44 »

Oh Mist, meine steten kleineren Reparaturen am Forum wurden bemerkt ...   ;D    ;)
Gespeichert
Vorsicht! Dieser Beitrag kann Spuren von Ironie oder Sarkasmus enthalten. Ohne Konservierungsstoffe (lt. Gesetz). Ohne Farbstoffe. Ohne geschmacksverstärkende Zusatzstoffe. Deckt 2% des Richtwertes des täglichen Benzintalkbedarfs.

Rütz

  • Oldi-Liebhaber
  • Forums-Urgestein
  • ******
  • Karma: 145
  • Offline
  • Beiträge: 6587
  • Seit 1983 mit R27 unterwegs...
    • 51647
    • Gummersbach
  • Mitglied seit: 21/08/2002
    YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
Re: Suche geht nicht mehr?
« Antwort #16 am: 20 Juli 2009, 12:26:08 »

 :applaus: :blumen:
Gespeichert
"Das Gegenteil von Freiheit ist Gesundheit"  (Juli Zeh, 2017)

BMW Einzylinder-Forum

« am: »

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 

anything
anything